<!doctype html > <!--[if IE 8]> <html class=" ie8 _7g " lang="en"> <![endif]--> <!--[if IE 9]> <html class=" ie9 _7h " lang="en"> <![endif]--> <!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]--> <head>
<meta charset="UTF-8"> <title>Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon - MySmartPrice</title> <meta name="viewport" content="width=device-width, initial-scale=1.0"> <link rel="pingback" href="https://www.mysmartprice.com/gear/xmlrpc.php" /> <meta property="og:image" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg" /><link rel="icon" type="image/png" href="https://www.mysmartprice.com/favicon.ico">  <meta name="news_keywords" content="" /> <meta name="original-source" content="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/" /> <link rel="canonical" href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/" /> <meta property="og:locale" content="en_US" /> <meta property="og:type" content="article" /> <meta property="og:title" content="Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon - MySmartPrice" /> <meta property="og:description" content="Xiaomi is all geared up to launch the Xiaomi Mi Watch alongside the Mi CC9 Pro and the Mi TV 5 today (November 5). The Mi Watch will be the company&#8217;s first-ever smartwatch. That said, it certainly won&#8217;t be the last as the company is reportedly working on launching the pro variant of the Mi &hellip;" /> <meta property="og:url" content="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/" /> <meta property="og:site_name" content="MySmartPrice" /> <meta property="article:publisher" content="https://www.facebook.com/mysmartprice/" /> <meta property="article:section" content="News" /> <meta property="article:published_time" content="2019-11-05T16:17:32+05:30" /> <meta property="og:image" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg" /> <meta property="og:image:secure_url" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg" /> <meta property="og:image:width" content="1200" /> <meta property="og:image:height" content="800" /> <meta name="twitter:card" content="summary" /> <meta name="twitter:description" content="Xiaomi is all geared up to launch the Xiaomi Mi Watch alongside the Mi CC9 Pro and the Mi TV 5 today (November 5). The Mi Watch will be the company&#8217;s first-ever smartwatch. That said, it certainly won&#8217;t be the last as the company is reportedly working on launching the pro variant of the Mi [&hellip;]" /> <meta name="twitter:title" content="Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon - MySmartPrice" /> <meta name="twitter:site" content="@mysmartprice" /> <meta name="twitter:image" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg" /> <meta name="twitter:creator" content="@stufflistings" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.mysmartprice.com\/gear\/","name":"MySmartPrice","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.mysmartprice.com\/gear\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.mysmartprice.com\/gear\/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon\/","sameAs":["https:\/\/www.facebook.com\/mysmartprice\/","https:\/\/twitter.com\/mysmartprice"],"@id":"#organization","name":"MySmartPrice","logo":"https:\/\/assets.mspcdn.net\/fl_lossy\/logos\/mysmartprice\/owl\/white@2x.png"}</script>  <link rel="alternate" type="application/rss+xml" title="MySmartPrice &raquo; Feed" href="https://www.mysmartprice.com/gear/feed/" /> <link rel="alternate" type="application/rss+xml" title="MySmartPrice &raquo; Comments Feed" href="https://www.mysmartprice.com/gear/comments/feed/" /> <link rel='dns-prefetch' href='//fonts.googleapis.com'> <link rel='dns-prefetch' href='//html5shim.googlecode.com'> <link rel='dns-prefetch' href='//sb.scorecardresearch.com'> <link rel='dns-prefetch' href='//assets.mspimages.in'> <link rel='dns-prefetch' href='//secure.gravatar.com'> <link rel='dns-prefetch' href='//assets.mspcdn.net'><link rel="alternate" type="application/rss+xml" title="MySmartPrice &raquo; Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon Comments Feed" href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/feed/" /> <style id="critical-css">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</style> <link rel='stylesheet' href='//fonts.googleapis.com/css?family=Poppins%3A500%2C600&#038;ver=4.9' type='text/css' media='all' /> <script data-dont-merge>window.swift_performance_collectdomready = [];window.swift_performance_collectready = [];window.swift_performance_collectonload = [];</script> <link rel='https://api.w.org/' href='https://www.mysmartprice.com/gear/wp-json/' /> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mysmartprice.com/gear/xmlrpc.php?rsd" /> <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mysmartprice.com/gear/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 4.9" /> <link rel='shortlink' href='https://www.mysmartprice.com/gear/?p=168828' /> <link rel="alternate" type="application/json+oembed" href="https://www.mysmartprice.com/gear/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mysmartprice.com%2Fgear%2Fxiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.mysmartprice.com/gear/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mysmartprice.com%2Fgear%2Fxiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon%2F&#038;format=xml" /> <!--[if lt IE 9]><script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--> <link rel="amphtml" href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/amp/" /><meta name="twitter:widgets:link-color" content="#000000"><meta name="twitter:widgets:border-color" content="#000000"><meta name="twitter:partner" content="tfwp">        <noscript> <img src="//sb.scorecardresearch.com/p?c1=2&c2=15357669&cv=2.0&cj=1"/> </noscript>   <script>
       !function(n,e){var t,o,i,c=[],f={passive:!0,capture:!0},r=new Date,a="pointerup",u="pointercancel";function p(n,c){t||(t=c,o=n,i=new Date,w(e),s())}function s(){o>=0&&o<i-r&&(c.forEach(function(n){n(o,t)}),c=[])}function l(t){if(t.cancelable){var o=(t.timeStamp>1e12?new Date:performance.now())-t.timeStamp;"pointerdown"==t.type?function(t,o){function i(){p(t,o),r()}function c(){r()}function r(){e(a,i,f),e(u,c,f)}n(a,i,f),n(u,c,f)}(o,t):p(o,t)}}function w(n){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(e){n(e,l,f)})}w(n),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){c.push(n),s()}}(addEventListener,removeEventListener);
        var isMobile = /iPhone|iPad|iPod|Android/i.test(navigator.userAgent);
        if(isMobile) {
               device = 'mobile';
        } else {
               device = 'desktop';
        }
        observerId = (new Date()).getTime();
        observerUrl = window.location.href;
        const observer_paint = new PerformanceObserver((list) => {
            var perfEntries = list.getEntries();
            for (var i = 0; i < perfEntries.length; i++) {
                const metricName = perfEntries[i].name;
                timingValue = Math.round(perfEntries[i].startTime + perfEntries[i].duration);
            }
        });
        observer_paint.observe({entryTypes: ["paint"]});

        const observer2 = new PerformanceObserver((list) => {
            for (const entry2 of list.getEntries()) {
                if(entry2.name==location.href){
                    metricName = "page_load_complete";
                    timingValue = Math.round(entry2.duration+0);

                    var perfData = window.performance.timing; 
                    metricName = "dcl";
                    timingValue = Math.round(perfData.domContentLoadedEventStart -  perfData.domLoading);
                }
            }
        });
        observer2.observe({entryTypes: ["navigation"]});

    perfMetrics.onFirstInputDelay(function(delay, evt) {
            console.log(evt.type);
            console.log('delay '+Math.round(delay));
        });

</script> <script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.mysmartprice.com/gear/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.mysmartprice.com/gear/category/news/",
                                "name": "News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/",
                                "name": "Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the..."                                
                            }
                        }    ]
                        }
                       </script> <meta name="twitter:card" content="summary"><meta name="twitter:title" content="Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon"><meta name="twitter:site" content="@MySmartPrice"><meta name="twitter:description" content="Xiaomi is all geared up to launch the Xiaomi Mi Watch alongside the Mi CC9 Pro and the Mi TV 5 today (November 5). The Mi Watch will be the company&#039;s first-ever smartwatch. That said, it certainly won&#039;t be the last as the company is reportedly working on launching the pro variant of the Mi&hellip;"><meta name="twitter:image" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg"><meta name="twitter:image:alt" content="Mi Watch"><meta name="twitter:creator" content="@stufflistings"> <script data-dont-merge="">(function(){function iv(a){if(typeof a.getBoundingClientRect!=='function'){return false}var b=a.getBoundingClientRect();return((a.innerHeight||a.clientHeight)>0&&b.bottom+50>=0&&b.right+50>=0&&b.top-50<=(window.innerHeight||document.documentElement.clientHeight)&&b.left-50<=(window.innerWidth||document.documentElement.clientWidth))}function ll(){var a=document.querySelectorAll('[data-swift-image-lazyload]');for(var i in a){if(iv(a[i])){a[i].onload=function(){window.dispatchEvent(new Event('resize'));};a[i].setAttribute('src',(typeof a[i].dataset.src != 'undefined' ? a[i].dataset.src : a[i].src));a[i].setAttribute('srcset',a[i].dataset.srcset);a[i].setAttribute('style',a[i].dataset.style);a[i].removeAttribute('data-swift-image-lazyload')}}requestAnimationFrame(ll)}requestAnimationFrame(ll)})();</script><script data-dont-merge="">(function(){function iv(a){if(typeof a.getBoundingClientRect!=='function'){return false}var b=a.getBoundingClientRect();return(b.bottom+50>=0&&b.right+50>=0&&b.top-50<=(window.innerHeight||document.documentElement.clientHeight)&&b.left-50<=(window.innerWidth||document.documentElement.clientWidth))}function ll(){var a=document.querySelectorAll('[data-swift-iframe-lazyload]');for(var i in a){if(iv(a[i])){a[i].onload=function(){window.dispatchEvent(new Event('resize'));};a[i].setAttribute('src',(typeof a[i].dataset.src != 'undefined' ? a[i].dataset.src : a[i].src));a[i].setAttribute('srcset',a[i].dataset.srcset);a[i].setAttribute('style',a[i].dataset.style);a[i].removeAttribute('data-swift-iframe-lazyload')}}requestAnimationFrame(ll)}var fire=function(){window.removeEventListener("touchstart",fire);window.removeEventListener("scroll",fire);document.removeEventListener("mousemove",fire);requestAnimationFrame(ll)};window.addEventListener("touchstart",fire,true);window.addEventListener("scroll",fire,true);document.addEventListener("mousemove",fire);})();</script></head> <body class=" post-template-default single _45 single-post _8i postid-168828 single-format-standard xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon global-block-template-1 white-menu td-animation-stack-type0 td-boxed-layout _l " itemscope="itemscope" itemtype="https://schema.org/WebPage"> <div class=" td-scroll-up _6c "><i class=" td-icon-menu-up _4m "></i></div> <div class=" td-menu-background _19 "></div> <div id="td-mobile-nav"> <div class=" td-mobile-container _1j ">  <div class=" td-menu-socials-wrap ">  <div class=" td-menu-socials _1c "> <span class=" td-social-icon-wrap _17 "> <a rel="nofollow" target="_blank" href="https://www.facebook.com/mysmartprice/" title="Facebook"> <i class=" td-icon-font _18 td-icon-facebook _3e "></i> </a> </span> <span class=" td-social-icon-wrap _17 "> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cDovL215c21hcnRwcmljZS5jb20vZ2Vhci9mZWVkLw=="> <i class=" td-icon-font _18 td-icon-rss _4p "></i> </a> </span> <span class=" td-social-icon-wrap _17 "> <a rel="nofollow" target="_blank" href="https://twitter.com/mysmartprice" title="Twitter"> <i class=" td-icon-font _18 td-icon-twitter _3g "></i> </a> </span> <span class=" td-social-icon-wrap _17 "> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cHM6Ly93d3cueW91dHViZS5jb20vdXNlci9NeVNtYXJ0UHJpY2U="> <i class=" td-icon-font _18 td-icon-youtube _4q "></i> </a> </span> </div>  <div class=" td-mobile-close _1d "> <a href="#"><i class=" td-icon-close-mobile _1e "></i></a> </div> </div>   <div class=" td-mobile-content _1f "> <div class=" menu-top-menu-container "><ul id="menu-top-menu" class=" td-mobile-main-menu "><li id="menu-item-1481" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-1481 "><a href="https://www.mysmartprice.com/gear" itemprop="url">Home</a></li> <li id="menu-item-1349" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1349 "><a href="https://www.mysmartprice.com/gear/category/news/" itemprop="url">Tech News</a></li> <li id="menu-item-78315" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-78315 "><a href="https://www.mysmartprice.com/gear/category/leaks/" itemprop="url">Leaks</a></li> <li id="menu-item-1350" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1350 "><a href="https://www.mysmartprice.com/gear/category/features/" itemprop="url">Features</a></li> <li id="menu-item-1351" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1351 "><a href="https://www.mysmartprice.com/gear/category/reviews/" itemprop="url">Product Reviews</a></li> <li id="menu-item-138307" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-138307 "><a href="https://www.mysmartprice.com/mobile/oneplus-7t-pro-msp15861" itemprop="url">OnePlus 7T Pro</a></li> <li id="menu-item-147203" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-147203 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-note-8-msp15859" itemprop="url">Redmi Note 8</a></li> <li id="menu-item-154737" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-154737 "><a href="https://www.mysmartprice.com/mobile/oneplus-7t-msp15897" itemprop="url">OnePlus 7T</a></li> <li id="menu-item-49532" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-49532 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-8a-msp15938" itemprop="url">Redmi 8A</a></li> <li id="menu-item-79091" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-79091 "><a href="https://www.mysmartprice.com/mobile/realme-xt-msp15881" itemprop="url">Realme XT</a></li> </ul></div> </div> </div>  </div> <div class=" td-search-background _1s "></div> <div class=" td-search-wrap-mob _1o "> <div class=" td-drop-down-search _11 " aria-labelledby="td-header-search-button"> <form method="get" class=" td-search-form _14 " action="https://www.mysmartprice.com/gear/">  <div class=" td-search-close _1t "> <a href="#"><i class=" td-icon-close-mobile _1e "></i></a> </div> <div role="search" class=" td-search-input _1p "> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /> </div> </form> <div id="td-aj-search-mob"></div> </div> </div> <div id="td-outer-wrap" class=" td-theme-wrap _dj ">  <div class=" td-header-wrap _e td-header-style-3 _p "> <div class=" td-header-top-menu-full _m td-container-wrap _66 td_stretch_container _6b "> <div class=" td-container _3 td-header-row _f td-header-top-menu _16 ">  </div> </div> <div class=" td-banner-wrap-full _n td-container-wrap _66 td_stretch_container _6b "> <div class=" td-container _3 td-header-row _f td-header-header "> <div class=" td-header-sp-logo _g "> <a class=" td-main-logo " href="https://www.mysmartprice.com"> <img class=" td-retina-data " data-retina="https://assets.mspimages.in/logos/mysmartprice/owl/blue@2x.png" src="//assets.mspimages.in/logos/mysmartprice/owl/blue.png" alt="MySmartPrice News" title="MySmartPrice News" /> <span class=" td-visual-hidden _i ">MySmartPrice</span> </a> </div> </div> </div> <div class=" td-header-menu-wrap-full _o td-container-wrap _66 td_stretch_container _6b "> <div class=" td-header-menu-wrap _j "> <div class=" td-container _3 td-header-row _f td-header-main-menu _t black-menu _9u "> <div id="td-header-menu" role="navigation"> <div id="td-top-mobile-toggle"><a href="#"><i class=" td-icon-font _18 td-icon-mobile _4r "></i></a></div> <div class=" td-main-menu-logo _h td-logo-in-header "> <a class=" td-main-logo " href="https://www.mysmartprice.com"> <img class=" td-retina-data " data-retina="https://assets.mspimages.in/logos/mysmartprice/owl/blue@2x.png" src="//assets.mspimages.in/logos/mysmartprice/owl/blue.png" alt="MySmartPrice News" title="MySmartPrice News" /> </a> </div> <div class=" menu-top-menu-container "><ul id="menu-top-menu-1" class=" sf-menu _u "><li class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item _v td-normal-menu _w menu-item-1481 "><a href="https://www.mysmartprice.com/gear" itemprop="url">Home</a></li> <li class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item _v td-normal-menu _w menu-item-1349 "><a href="https://www.mysmartprice.com/gear/category/news/" itemprop="url">Tech News</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-78315 "><a href="https://www.mysmartprice.com/gear/category/leaks/" itemprop="url">Leaks</a></li> <li class=" menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item _v td-normal-menu _w menu-item-1350 "><a href="https://www.mysmartprice.com/gear/category/features/" itemprop="url">Features</a></li> <li class=" menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item _v td-normal-menu _w menu-item-1351 "><a href="https://www.mysmartprice.com/gear/category/reviews/" itemprop="url">Product Reviews</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-138307 "><a href="https://www.mysmartprice.com/mobile/oneplus-7t-pro-msp15861" itemprop="url">OnePlus 7T Pro</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-147203 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-note-8-msp15859" itemprop="url">Redmi Note 8</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-154737 "><a href="https://www.mysmartprice.com/mobile/oneplus-7t-msp15897" itemprop="url">OnePlus 7T</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-49532 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-8a-msp15938" itemprop="url">Redmi 8A</a></li> <li class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-79091 "><a href="https://www.mysmartprice.com/mobile/realme-xt-msp15881" itemprop="url">Realme XT</a></li> </ul></div></div> <div class=" td-search-wrapper "> <div id="td-top-search">  <div class=" header-search-wrap _r "> <div class=" dropdown header-search "> <a id="td-header-search-button" href="#" role="button" class=" dropdown-toggle " data-toggle="dropdown"><i class=" td-icon-search _s "></i></a> <a id="td-header-search-button-mob" href="#" role="button" class=" dropdown-toggle " data-toggle="dropdown"><i class=" td-icon-search _s "></i></a> </div> </div> </div> </div> <div class=" header-search-wrap _r "> <div class=" dropdown header-search "> <div class=" td-drop-down-search _11 " aria-labelledby="td-header-search-button"> <form method="get" class=" td-search-form _14 " action="https://www.mysmartprice.com/gear/"> <div role="search" class=" td-head-form-search-wrap "> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class=" wpb_button _4i wpb_btn-inverse btn _12 " type="submit" id="td-header-search-top" value="Search" /> </div> </form> <div id="td-aj-search"></div> </div> </div> </div> </div> </div> </div> <div class=" td-header-sp-recs _q "> <div class=" td-header-rec-wrap _5b "> <div class=" td-a-rec _54 td-a-rec-id-header _7j td_uid_1_5dc168efdcb16_rand td_block_template_1 _3u "><div class=" td-visible-desktop _55 " style='margin:auto;text-align:center;'> <div id='div-gpt-d-728-pos1' style='margin:auto;text-align:center;'> </div> </div> <div class=" td-visible-phone _56 " style='margin:auto;text-align:center;'> <div id="div-gpt-m-320-100-pos1" style="margin:auto;text-align:center;"> </div> </div></div> </div> </div> </div> <div class=" td-main-content-wrap _2 td-container-wrap _66 "> <div class=" td-container _3 td-post-template-default _41 "> <div class=" td-crumb-container _31 "><div class=" entry-crumbs _32 "><span><a title="" class=" entry-crumb " href="https://www.mysmartprice.com/gear/">Home</a></span> <i class=" td-icon-right _4l td-bread-sep _33 "></i> <span><a title="View all posts in News" class=" entry-crumb " href="https://www.mysmartprice.com/gear/category/news/">News</a></span> <i class=" td-icon-right _4l td-bread-sep _33 td-bred-no-url-last _8j "></i> <span class=" td-bred-no-url-last _8j ">Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the...</span></div></div> <div class=" td-pb-row _5 "> <div class=" td-pb-span8 _b td-main-content _8g " role="main"> <div class=" td-ss-main-content "> <article id="post-168828" class=" post-168828 post _35 type-post status-publish format-standard has-post-thumbnail hentry category-news category-smartwatches-fitness-trackers-wearables " itemscope itemtype="https://schema.org/NewsArticle"> <div class=" td-post-header _84 "> <ul class=" td-category _34 "><li class=" entry-category "><a href="https://www.mysmartprice.com/gear/category/news/">News</a></li><li class=" entry-category "><a href="https://www.mysmartprice.com/gear/category/news/smartwatches-fitness-trackers-wearables/">Smartwatches, Fitness Trackers, &amp; Wearables</a></li></ul> <header class=" td-post-title _42 "> <h1 class=" entry-title _36 ">Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon</h1> <div class=" td-module-meta-info _27 "> <div class=" td-post-author-name _28 "><div class=" td-author-by ">By</div> <a href="https://www.mysmartprice.com/gear/author/mukul/">Mukul Sharma</a><div class=" td-author-line "> - </div> </div> <span class=" td-post-date _1q ">Published On: <time class=" entry-date updated td-module-date " datetime="2019-11-05T16:17:32+00:00">Nov 5, 2019</time> | Last Updated: <time class=" entry-date updated td-module-date " datetime="2019-11-05T16:17:32+00:00">Nov 5, 2019</time></span> <div class=" td-post-comments _37 "><a href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/#respond"><i class=" td-icon-comments _38 "></i>0</a></div> </div> </header> </div> <div class=" td-post-sharing _39 td-post-sharing-top _8k "> <div class=" td-default-sharing _3a "> <a rel="nofollow" class=" td-social-sharing-buttons _3b td-social-facebook _3d " href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mysmartprice.com%2Fgear%2Fxiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class=" td-icon-facebook _3e "></i><div class=" td-social-but-text _3c ">Share on Facebook</div></a> <a rel="nofollow" class=" td-social-sharing-buttons _3b td-social-twitter _3f " href="https://twitter.com/intent/tweet?text=Xiaomi+Mi+Watch+Pro+with+a+Circular+Dial+to+Reportedly+in+the+Works%2C+Might+Launch+Soon&url=https%3A%2F%2Fwww.mysmartprice.com%2Fgear%2Fxiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon%2F&via=MySmartPrice"><i class=" td-icon-twitter _3g "></i><div class=" td-social-but-text _3c ">Tweet on Twitter</div></a> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cHM6Ly9wbHVzLmdvb2dsZS5jb20vc2hhcmU/dXJsPWh0dHBzOi8vd3d3Lm15c21hcnRwcmljZS5jb20vZ2Vhci94aWFvbWktbWktd2F0Y2gtcHJvLWNpcmN1bGFyLWRpYWwtcmVwb3J0ZWRseS13b3Jrcy1taWdodC1sYXVuY2gtc29vbi8="><i class=" td-icon-googleplus _4n "></i></a> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cHM6Ly9waW50ZXJlc3QuY29tL3Bpbi9jcmVhdGUvYnV0dG9uLz91cmw9aHR0cHM6Ly93d3cubXlzbWFydHByaWNlLmNvbS9nZWFyL3hpYW9taS1taS13YXRjaC1wcm8tY2lyY3VsYXItZGlhbC1yZXBvcnRlZGx5LXdvcmtzLW1pZ2h0LWxhdW5jaC1zb29uLyZhbXA7bWVkaWE9aHR0cHM6Ly9hc3NldHMubXNwaW1hZ2VzLmluL3dwLWNvbnRlbnQvdXBsb2Fkcy8yMDE5LzEwL21pLXdhdGNoMTI4MC5qcGcmZGVzY3JpcHRpb249WGlhb21pK01pK1dhdGNoK1Bybyt3aXRoK2ErQ2lyY3VsYXIrRGlhbCt0bytSZXBvcnRlZGx5K2luK3RoZStXb3JrcyUyQytNaWdodCtMYXVuY2grU29vbg=="><i class=" td-icon-pinterest _4o "></i></a> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/d2hhdHNhcHA6Ly9zZW5kP3RleHQ9WGlhb21pK01pK1dhdGNoK1Bybyt3aXRoK2ErQ2lyY3VsYXIrRGlhbCt0bytSZXBvcnRlZGx5K2luK3RoZStXb3JrcyUyQytNaWdodCtMYXVuY2grU29vbiUyMC0lMjBodHRwcyUzQSUyRiUyRnd3dy5teXNtYXJ0cHJpY2UuY29tJTJGZ2VhciUyRnhpYW9taS1taS13YXRjaC1wcm8tY2lyY3VsYXItZGlhbC1yZXBvcnRlZGx5LXdvcmtzLW1pZ2h0LWxhdW5jaC1zb29uJTJG"><i class=" td-icon-whatsapp _4s "></i></a> </div></div> <div class=" td-post-content _1w "> <div class=" td-post-featured-image _40 "><img width="696" height="464" class=" entry-thumb _26 " src="//assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-696x464.jpg" srcset="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-696x464.jpg 696w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-300x200.jpg 300w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-768x512.jpg 768w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-1024x683.jpg 1024w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-1068x712.jpg 1068w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-630x420.jpg 630w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-50x33.jpg 50w, https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg 1200w" sizes="(max-width: 696px) 100vw, 696px" alt="Mi Watch" title="Mi Watch" /></div> <p>Xiaomi is all geared up to launch the Xiaomi Mi Watch alongside the Mi CC9 Pro and the Mi TV 5 today (November 5). The Mi Watch will be the company&#8217;s first-ever smartwatch. That said, it certainly won&#8217;t be the last as the company is reportedly working on launching the pro variant of the Mi Watch pretty soon (not today though).</p> <h2><strong>Xioami Mi Watch Pro tipped to feature a circular dial</strong></h2> <p>The standard Mi Watch comes with a square dial which might not be everyone&#8217;s first choice. Thankfully enough, its Pro variant won&#8217;t be just a software bump-up and we will see a design change as well.</p> <p>The news has popped up on the internet courtesy of a tipster @Digital Chat Station. The handle has leaked the news on the Chinese microblogging website Weibo.</p> <div class=" td-a-rec _54 td-a-rec-id-content_inline _5e td_uid_2_5dc168efe22cc_rand td_block_template_1 _3u "><div class=" td-visible-desktop _55 " style='margin:auto;text-align:center;'> <div id='div-gpt-d-728-pos2' style='margin:auto;text-align:center;'> </div> </div> <div class=" td-visible-phone _56 " style='margin:auto;text-align:center;'> <div id="div-gpt-m-320-100-pos2" style="margin:auto;text-align:center;"> </div> </div></div><p><img class=" alignnone _21 wp-image-168830 size-full " src="//assets.mspimages.in/wp-content/uploads/2019/11/Mi-Watch-Pro.png" alt="Mi Watch Pro" width="668" height="294" srcset="https://assets.mspimages.in/wp-content/uploads/2019/11/Mi-Watch-Pro.png 668w, https://assets.mspimages.in/wp-content/uploads/2019/11/Mi-Watch-Pro-300x132.png 300w, https://assets.mspimages.in/wp-content/uploads/2019/11/Mi-Watch-Pro-50x22.png 50w" sizes="(max-width: 668px) 100vw, 668px" /></p> <p>The post clearly suggests that there will indeed be a Mi Watch Pro which will feature a round dial. The exact timing for the launch is not confirmed as of now, but the major chunk of the specifications of the device will be taken from the <span style="text-decoration: underline"><a href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-will-run-miui-watch-skin-equip-snapdragon-wear-3100-processor/"><strong>Mi Watch</strong></a></span>. We can expect the Mi Watch Pro to feature an e-SIM capability. Furthermore, the presence of the company&#8217;s MIUI for Watch OS is more than confirmed. It would, however, be interesting to see some new watch faces coming up with the Mi Watch Pro as the same will have a round dial.</p> <p>Additionally, we will be getting NFC for making online payments, health tracking, notifications alerts, music playback, e-SIM card support, FM radio, and pretty much all the features an ideal smartwatch should have.</p> <p>Speaking of the Mi Watch, Xiaomi has finally unveiled its first-ever smartwatch today. The watch is kept at an asking price of Yuan 1299 in China.</p> <p>As far as its design is concerned, it has an uncanny resemblance to the Apple Watch which is not a bad thing by any means. We get a curved display on the top of the watch, a ceramic bottom, and a crown on the right. The frame is made up of aluminum alloy and the Fluoride-based bands are swappable. Peeking at the display, we see a 1.78-inch AMOLED display with a substantial 326ppi pixel density. The Mi Watch comes pre-installed with up to 40 essential apps out of the box, including the likes of apps like QQ Chat, QQ Music, Google Keep, and many more.</p> <p>As of now, there is not much known about the Mi Watch Pro, but we are sure to receive further intel on the same in the coming days. As far as the launch date is concerned, the world of rumors suggests that we will get to see the launch of the Mi Watch Pro during the Redmi K30 series launch, but this is also not 100% confirmed as of now, so this news should also be counted as unconfirmed as of now.</p> <p>What are your thoughts on the Mi Watch Pro? What all upgrades do you expect it to have over the standard Mi Watch? Do let us know in the comments section below.</p> <div class=" td-a-rec _54 td-a-rec-id-content_bottom _5d td_uid_3_5dc168efe241e_rand td_block_template_1 _3u "><br /> <div class=" td-visible-desktop _55 " style='margin:auto;text-align:center;' clearfix> <div id='div-gpt-d-728-pos3' style='margin:auto;text-align:center;'> </div> </div> <div class=" td-visible-phone _56 " style='margin:auto;text-align:center;'> <div id="div-gpt-m-300-250-pos3" style="margin:auto;text-align:center;"> </div> </div> </div> </div> <footer> <div class=" td-post-source-tags _3h " style="padding-top:10px"> <div class=" td-post-source-via _3j td-no-tags _3i "><div class=" td-post-small-box _3k "><span>SOURCE</span><a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cHM6Ly93d3cuZ2l6Y2hpbmEuY29tLzIwMTkvMTEvMDQveGlhb21pLXdhdGNoLXByby1pcy1pbi10aGUtd29ya3MtdG9vLWJ1dC1ub3QtY29taW5nLXNvLXNvb24v">GizChina</a></div></div> </div> <div class=" author-box-wrap _3l "><a href="https://www.mysmartprice.com/gear/author/mukul/"><img alt='' src='//secure.gravatar.com/avatar/0e7eaa4470ef3f97976593fdc5790891?s=96&#038;d=mm&#038;r=g' srcset="https://secure.gravatar.com/avatar/0e7eaa4470ef3f97976593fdc5790891?s=192&#038;d=mm&#038;r=g 2x" class=' avatar _3m avatar-96 photo ' height='96' width='96' /></a><div class=" desc _3n "><div class=" td-author-name _3p vcard author "><span class=" fn "><a href="https://www.mysmartprice.com/gear/author/mukul/">Mukul Sharma</a></span></div><div class=" td-author-description _er "><p>Known more as Stuff Listings. An old professor who knows more tech than his students</p> </div><div class=" td-author-social _3o "> <span class=" td-social-icon-wrap _17 "> <a rel="nofollow" target="_blank" href="https://twitter.com/stufflistings" title="Twitter"> <i class=" td-icon-font _18 td-icon-twitter _3g "></i> </a> </span></div><div class=" clearfix _0 "></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Mukul Sharma"></span><meta itemprop="datePublished" content="2019-11-05T16:17:32+05:30"><meta itemprop="dateModified" content="2019-11-05T16:17:32+05:30"><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/" /><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://assets.mspimages.in/logos/mysmartprice/owl/blue.png"></span><meta itemprop="name" content="MySmartPrice Gear"></span><meta itemprop="headline " content="Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="800"></span> </footer> </article>  <div class=" td_block_wrap _2a td_block_related_posts _3s td_uid_4_5b699aae59ce3_rand td_with_ajax_pagination _2b td-pb-border-top td_block_template_1 _3u " data-td-block-uid="td_uid_4_5b699aae59ce3"><div class=" td-related-title _3v td-block-title _30 "><a id="td_uid_5_5b699aae6aedb" class=" td-related-left _3w td-cur-simple-item _2s " data-td_filter_value="" data-td_block_id="td_uid_4_5b699aae59ce3" href="#">RELATED ARTICLES</a></div><div id="td_uid_4_5b699aae59ce3" class=" td_block_inner "><div class=" td-related-row _3q "><div class=" td-related-span4 _3r "> <div class=" td_module_related_posts td-animation-stack td_mod_related_posts _by "> <div class=" td-module-image _29 "> <div class=" td-module-thumb _1r "><a href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-will-run-miui-watch-skin-equip-snapdragon-wear-3100-processor/" rel="bookmark" title="Xiaomi Mi Watch Will Run &#8216;MIUI For Watch&#8217; Skin and Equip Snapdragon Wear 3100 Processor"><img width="150" height="150" src="//assets.mspimages.in/wp-content/uploads/2019/10/mi-watch1280-150x150.jpg" class=" attachment-thumbnail size-thumbnail " alt="Mi Watch" /></a></div> </div> <div class=" item-details _8l "> <div class=" entry-title _36 td-module-title _3t " style="margin-bottom:17px;"><a style="color:#000000;" href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-will-run-miui-watch-skin-equip-snapdragon-wear-3100-processor/" rel="bookmark" title="Xiaomi Mi Watch Will Run &#8216;MIUI For Watch&#8217; Skin and Equip Snapdragon Wear 3100 Processor">Xiaomi Mi Watch Will Run &#8216;MIUI For Watch&#8217; Skin and Equip Snapdragon Wear 3100 Processor</a></div> </div> </div> </div><div class=" td-related-span4 _3r "> <div class=" td_module_related_posts td-animation-stack td_mod_related_posts _by "> <div class=" td-module-image _29 "> <div class=" td-module-thumb _1r "><a href="https://www.mysmartprice.com/gear/xiaomi-mi-cc9-pro-108mp-camera-mi-tv-5-mi-watch-launch-china-november-5/" rel="bookmark" title="Xiaomi Mi CC9 Pro with 108MP Camera, Mi TV 5 and Mi Watch to Launch in China on November 5"><img width="150" height="150" src="//assets.mspimages.in/wp-content/uploads/2019/10/cc9-pro-live-leaked-image-150x150.jpg" class=" attachment-thumbnail size-thumbnail " alt="cc9 pro live leaked image" /></a></div> </div> <div class=" item-details _8l "> <div class=" entry-title _36 td-module-title _3t " style="margin-bottom:17px;"><a style="color:#000000;" href="https://www.mysmartprice.com/gear/xiaomi-mi-cc9-pro-108mp-camera-mi-tv-5-mi-watch-launch-china-november-5/" rel="bookmark" title="Xiaomi Mi CC9 Pro with 108MP Camera, Mi TV 5 and Mi Watch to Launch in China on November 5">Xiaomi Mi CC9 Pro with 108MP Camera, Mi TV 5 and Mi Watch to Launch in China on November 5</a></div> </div> </div> </div><div class=" td-related-span4 _3r "> <div class=" td_module_related_posts td-animation-stack td_mod_related_posts _by "> <div class=" td-module-image _29 "> <div class=" td-module-thumb _1r "><a href="https://www.mysmartprice.com/gear/lenovo-s5-pro-launching-today-china-watch-live-streaming-live-updates/" rel="bookmark" title="Lenovo S5 Pro Launching Today in China: Watch Live Streaming, Live Updates"><img width="150" height="150" src="//assets.mspimages.in/wp-content/uploads/2018/10/Lenovo-S5-Pro-Launch-150x150.png" class=" attachment-thumbnail size-thumbnail " alt="" /></a></div> </div> <div class=" item-details _8l "> <div class=" entry-title _36 td-module-title _3t " style="margin-bottom:17px;"><a style="color:#000000;" href="https://www.mysmartprice.com/gear/lenovo-s5-pro-launching-today-china-watch-live-streaming-live-updates/" rel="bookmark" title="Lenovo S5 Pro Launching Today in China: Watch Live Streaming, Live Updates">Lenovo S5 Pro Launching Today in China: Watch Live Streaming, Live Updates</a></div> </div> </div> </div></div><div class=" td-related-row _3q "><div class=" td-related-span4 _3r "> <div class=" td_module_related_posts td-animation-stack td_mod_related_posts _by "> <div class=" td-module-image _29 "> <div class=" td-module-thumb _1r "><a href="https://www.mysmartprice.com/gear/2018/08/23/oppo-r17-r17-pro-launch-china-today-watch-live-streaming-live-updates/" rel="bookmark" title="Oppo R17, R17 Pro Launch Event Starts: Watch Live Streaming, Live Updates"><img width="150" height="150" src="//assets.mspimages.in/wp-content/uploads/2018/08/Oppo-R17-Launch-Event-150x150.jpg" class=" attachment-thumbnail size-thumbnail " alt="" /></a></div> </div> <div class=" item-details _8l "> <div class=" entry-title _36 td-module-title _3t " style="margin-bottom:17px;"><a style="color:#000000;" href="https://www.mysmartprice.com/gear/2018/08/23/oppo-r17-r17-pro-launch-china-today-watch-live-streaming-live-updates/" rel="bookmark" title="Oppo R17, R17 Pro Launch Event Starts: Watch Live Streaming, Live Updates">Oppo R17, R17 Pro Launch Event Starts: Watch Live Streaming, Live Updates</a></div> </div> </div> </div><div class=" td-related-span4 _3r "> <div class=" td_module_related_posts td-animation-stack td_mod_related_posts _by "> <div class=" td-module-image _29 "> <div class=" td-module-thumb _1r "><a href="https://www.mysmartprice.com/gear/2017/05/02/fitbits-next-smartwatch-bluetooth-earphones-leaked/" rel="bookmark" title="Fitbit&#8217;s next smartwatch promising 4 days battery life and Bluetooth earphones leaked"><img width="150" height="150" src="//assets.mspimages.in/wp-content/uploads/2017/05/Fitbit-smartwatch-150x150.jpg" class=" attachment-thumbnail size-thumbnail " alt="Fitbit smartwatch" /></a></div> </div> <div class=" item-details _8l "> <div class=" entry-title _36 td-module-title _3t " style="margin-bottom:17px;"><a style="color:#000000;" href="https://www.mysmartprice.com/gear/2017/05/02/fitbits-next-smartwatch-bluetooth-earphones-leaked/" rel="bookmark" title="Fitbit&#8217;s next smartwatch promising 4 days battery life and Bluetooth earphones leaked">Fitbit&#8217;s next smartwatch promising 4 days battery life and Bluetooth earphones leaked</a></div> </div> </div> </div></div></div></div> <div class=' td-visible-desktop _55 ' style='margin:auto;text-align:center;'> <div id='div-gpt-d-300-250-pos2' style='margin:auto;text-align:center;'> </div> </div> <div class=' td-visible-phone _56 ' style='margin:auto;text-align:center;'> <div id='div-gpt-m-300-250-pos2' style='margin:auto;text-align:center;'> </div> </div><section class=" social-links _et "> <div class=" social-links__others _eu "> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cHM6Ly93d3cueW91dHViZS5jb20vbXlzbWFydHByaWNl" class=" sctn--ftr__scl _ew sctn--ftr__scl--yt _f0 "></a> <a class=" sctn--ftr__scl _ew sctn--ftr__scl--fb _ex " target="_blank" rel="nofollow" href="https://www.facebook.com/mysmartprice/"></a> <a class=" sctn--ftr__scl _ew sctn--ftr__scl--twttr _f1 " target="_blank" rel="nofollow" href="https://twitter.com/mysmartprice"></a> <a class=" sctn--ftr__scl _ew sctn--ftr__scl--rss _ey " target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/feed/"></a> </div> <div class=" social-links__playstore _ev "> <a target="_blank" rel="nofollow" href="https://www.mysmartprice.com/gear/out/aHR0cDovL2luc3RhbGwubXlzbWFydHByaWNlLmNvbT9waWQ9U2l0ZUJvdHRvbUxpbms="> <img src="//assets.mspimages.in/msp-ui/icons/large/google-play-badge.png" srcset="https://assets.mspimages.in/msp-ui/icons/large/google-play-badge@2x.png" alt="google playstore link" class=" sctn--ftr__scl__img "> </a> </div> </section> <div class=" td-visible-desktop _55 " style="padding:5px"> <div id="taboola-below-article-gear"></div> </div> <div class=" td-visible-phone _56 " style="padding:5px"> <div id="taboola-mobile-carousel-thumbnails"></div> </div> <div class=" comments _46 " id="comments"> <div id="respond" class=" comment-respond _44 "> <h3 id="reply-title" class=" comment-reply-title ">LEAVE A REPLY <small></small></h3> <form action="https://www.mysmartprice.com/gear/wp-comments-post.php" method="post" id="commentform" class=" comment-form _47 " novalidate> <div class=" clearfix _0 "></div> <div class=" comment-form-input-wrap td-form-comment _4e "> <textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea> <div class=" td-warning-comment _49 ">Please enter your comment!</div> </div> <div class=" comment-form-input-wrap td-form-author _4d "> <input class=" " id="author" name="author" placeholder="Name:" type="text" value="" size="30" /> <div class=" td-warning-author _48 ">Please enter your name here</div> </div> <div class=" comment-form-input-wrap td-form-email _4f "> <input class=" " id="email" name="email" placeholder="Email:" type="text" value="" size="30" /> <div class=" td-warning-email-error _4b ">You have entered an incorrect email address!</div> <div class=" td-warning-email _4a ">Please enter your email address here</div> </div> <p class=" form-submit "><input name="submit" type="submit" id="submit" class=" submit _8m " value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='168828' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p> </form> </div> </div>  </div> </div> <div class=" td-pb-span4 _8 td-main-sidebar _92 " role="complementary"> <div class=" td-ss-main-sidebar _6 "> <aside class=" td_block_template_1 _3u widget _5s widget_search _5v "><div class=" block-title _2c "><span>Search</span></div><form method="get" class=" td-search-form-widget _4h " action="https://www.mysmartprice.com/gear/"> <div role="search"> <input class=" td-widget-search-input _4j " type="text" value="" name="s" id="s" /><input class=" wpb_button _4i wpb_btn-inverse btn _12 " type="submit" id="searchsubmit" value="Search" /> </div> </form></aside><div class=" td-a-rec _54 td-a-rec-id-sidebar _5m td-rec-hide-on-tl _81 td-rec-hide-on-tp _80 td-rec-hide-on-p _8o td_uid_4_5dc168f01626d_rand td_block_template_1 _3u "><div class=" td-visible-desktop _55 " style='margin:auto;text-align:center;'> <div id='div-gpt-d-300-250-pos1' style='margin:auto;text-align:center;'> </div> </div> <div class=" td-visible-phone _56 " style='margin:auto;text-align:center;'> <div id="div-gpt-m-300-250-pos1" style="margin:auto;text-align:center;"> </div> </div> <br /></div><aside class=" td_block_template_1 _3u widget _5s widget_nav_menu "><div class=" block-title _2c "><span>Popular Mobiles in India</span></div><div class=" menu-popular-mobiles-container "><ul id="menu-popular-mobiles" class=" menu "><li id="menu-item-7456" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item _v td-normal-menu _w menu-item-7456 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-note-8-pro-msp15887" itemprop="url">Redmi Note 8 Pro Price in India</a></li> <li id="menu-item-107370" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-107370 "><a href="https://www.mysmartprice.com/mobile/realme-5-pro-msp15873" itemprop="url">Realme 5 Pro</a></li> <li id="menu-item-69137" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-69137 "><a href="https://www.mysmartprice.com/mobile/realme-5-msp15879" itemprop="url">Realme 5 Price in India</a></li> <li id="menu-item-112845" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-112845 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-8-msp15886" itemprop="url">Redmi 8 Price</a></li> <li id="menu-item-79755" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-79755 "><a href="https://www.mysmartprice.com/mobile/motorola-moto-g8-plus-msp15926" itemprop="url">Moto G8 Plus</a></li> <li id="menu-item-163033" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-163033 "><a href="https://www.mysmartprice.com/mobile/vivo-z1x-msp15901" itemprop="url">Vivo Z1X</a></li> <li id="menu-item-78181" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-78181 "><a href="https://www.mysmartprice.com/mobile/apple-iphone-xi-max-msp15925" itemprop="url">iPhone 11 Pro Max</a></li> <li id="menu-item-144359" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-144359 "><a href="https://www.mysmartprice.com/mobile/nokia-7-2-msp15827" itemprop="url">Nokia 7.2</a></li> <li id="menu-item-117669" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-117669 "><a href="https://www.mysmartprice.com/mobile/xiaomi-redmi-note-7-pro-msp15392" itemprop="url">Redmi Note 7 Pro</a></li> <li id="menu-item-7483" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-7483 "><a href="https://www.mysmartprice.com/mobile/oneplus-7-pro--msp15614" itemprop="url">OnePlus 7 Pro Price in India</a></li> <li id="menu-item-122411" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-122411 "><a href="https://www.mysmartprice.com/mobile/oneplus-7-msp15403" itemprop="url">OnePlus 7</a></li> <li id="menu-item-113277" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-113277 "><a href="https://www.mysmartprice.com/mobile/vivo-z1-pro-msp15724" itemprop="url">Vivo Z1 Pro Price</a></li> </ul></div></aside> <aside class=" td_block_template_1 _3u widget _5s widget_recent_entries _5t "> <div class=" block-title _2c "><span>Recent Posts</span></div> <ul> <li> <a href="https://www.mysmartprice.com/gear/xiaomi-mi-tv-5-5-pro-smart-tvs-quantum-dot-display-hdr-10-launched-china-price-specs/">Xiaomi Mi TV 5, 5 Pro Smart TVs with Quantum Dot Display, HDR 10+ Launched in China: Price, Specs</a> <span class=" post-date _5u ">November 5, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/xiaomi-mi-watch-pro-circular-dial-reportedly-works-might-launch-soon/">Xiaomi Mi Watch Pro with a Circular Dial to Reportedly in the Works, Might Launch Soon</a> <span class=" post-date _5u ">November 5, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/xiaomi-mi-cc9-pro-108mp-penta-camera-setup-snapdragon-730g-soc-launched-price-features/">Xiaomi Mi CC9 Pro with 108MP Penta Camera Setup, Snapdragon 730G SoC Launched: Price, Features</a> <span class=" post-date _5u ">November 5, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/realme-xt-iconic-case-now-available-goes-sale-via-realme-online-store-india/">Realme XT Iconic Case Now Available; Goes on Sale Via Realme Online Store in India</a> <span class=" post-date _5u ">November 5, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/samsung-galaxy-fold-w20-5g-china-launch-set-november-8/">Samsung Galaxy Fold (W20 5G) China launch set for November 8</a> <span class=" post-date _5u ">November 5, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/samsung-galaxy-s11-launch-second-generation-108mp-camera-5x-optical-zoom-exynos-9830/">Samsung Galaxy S11 Could Launch With Second-Generation 108MP Camera, 5x Optical Zoom, Exynos 9830</a> <span class=" post-date _5u ">November 4, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/gopro-hero8-black-action-camera-4k-hypersmooth-video-recording-launched-india-price-availability/">GoPro Hero8 Black Action Camera With 4K HyperSmooth Video Recording Launched in India: Price, Availability</a> <span class=" post-date _5u ">November 4, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/beyerdynamic-blue-byrd-ear-bluetooth-earphones-aac-aptx-usb-type-c-port-launched-india-price-specs/">Beyerdynamic Blue BYRD In-Ear Bluetooth Earphones With AAC, aptX, USB Type-C Port Launched In India: Price, Specs</a> <span class=" post-date _5u ">November 4, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/nokia-800-tough-4g-feature-phone-ip68-mil-std-810g-rating-launch-india-soon/">Nokia 800 Tough 4G Feature Phone with IP68, MIL-STD-810G Rating to Launch in India Soon</a> <span class=" post-date _5u ">November 4, 2019</span> </li> <li> <a href="https://www.mysmartprice.com/gear/hifiman-tws600-truly-wireless-bluetooth-earphones-150-meters-range-38-6-hours-battery-life-launched-india-price-specs/">HIFIMan TWS600 Truly Wireless Bluetooth Earphones With 150 Meters Range, 38.6 Hours Battery Life Launched In India: Price, Specs</a> <span class=" post-date _5u ">November 4, 2019</span> </li> </ul> </aside><aside class=" widget_text _5w td_block_template_1 _3u widget _5s widget_custom_html "><div class=" textwidget custom-html-widget "><div id="taboola-right-rails-thumbnails"></div> </div></aside><aside class=" td_block_template_1 _3u widget _5s widget_nav_menu "><div class=" block-title _2c "><span>New Mobiles</span></div><div class=" menu-new-mobiles-container "><ul id="menu-new-mobiles" class=" menu "><li id="menu-item-17470" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item _v td-normal-menu _w menu-item-17470 "><a href="https://www.mysmartprice.com/mobile/vivo-s5-msp16129" itemprop="url">vivo s5</a></li> <li id="menu-item-17465" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17465 "><a href="https://www.mysmartprice.com/mobile/vivo-x50-msp16131" itemprop="url">vivo x50</a></li> <li id="menu-item-17441" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17441 "><a href="https://www.mysmartprice.com/mobile/xiaomi-mi-note-10-msp16107" itemprop="url">Mi Note 10</a></li> <li id="menu-item-17467" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17467 "><a href="https://www.mysmartprice.com/mobile/vivo-x50-pro-msp16132" itemprop="url">vivo x50 pro</a></li> <li id="menu-item-17466" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17466 "><a href="https://www.mysmartprice.com/mobile/xiaomi-qin-1s-msp16122" itemprop="url">Xiaomi Qin 1S</a></li> <li id="menu-item-17464" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17464 "><a href="https://www.mysmartprice.com/mobile/samsung-w20-5g-msp16130" itemprop="url">Samsung Galaxy W20 5G</a></li> <li id="menu-item-17468" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17468 "><a href="https://www.mysmartprice.com/mobile/xiaomi-mi-note-10-pro-msp16110" itemprop="url">Mi Note 10 Pro</a></li> <li id="menu-item-17469" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-17469 "><a href="https://www.mysmartprice.com/mobile/huawei-enjoy-10s-msp16109" itemprop="url">Huawei Enjoy 10S</a></li> </ul></div></aside><aside class=" widget_text _5w td_block_template_1 _3u widget _5s widget_custom_html "><div class=" textwidget custom-html-widget "><div id="div-gpt-second-sidebar" style="margin:0 auto 20px;text-align:center"> </div></div></aside> </div> </div> </div>  </div>  </div>    <div class=" td-footer-wrapper _60 td-container-wrap _66 td_stretch_container _6b "> <div class=" td-container _3 "> <div class=" td-pb-row _5 "> <div class=" td-pb-span12 _d "> <div class=" td-a-rec _54 td-a-rec-id-footer_top _5q td_uid_5_5dc168f02c8cc_rand td_block_template_1 _3u "><div class=" td-visible-desktop _55 " style='margin:auto;text-align:center;'> <div id='div-gpt-d-728-pos4' style='margin:auto;text-align:center;'> </div> </div> <div class=" td-visible-phone _56 " style='margin:auto;text-align:center;'> <div id="div-gpt-m-300-250-pos4" style="margin:auto;text-align:center;"> </div> </div></div> </div> </div> <div class=" td-pb-row _5 "> <div class=" td-pb-span12 _d "> </div> </div> </div> <div class=" td-footer-bottom-full _6j "> <div class=" td-container _3 "> <div class=" td-pb-row _5 "> <div class=" td-pb-span3 _a "><aside class=" footer-logo-wrap _6h "><a href="https://www.mysmartprice.com/gear/"><img src="//assets.mspimages.in/logos/mysmartprice/owl/blue@2x.png" alt="MySmartPrice News" title="MySmartPrice News" /></a></aside></div><div class=" td-pb-span9 _c "><aside class=" footer-text-wrap _6i "><div class=" block-title _2c "><span>ABOUT US</span></div></aside></div> </div> </div> </div> </div>  <div class=" td-sub-footer-container _6k td-container-wrap _66 td_stretch_container _6b "> <div class=" td-container _3 "> <div class=" td-pb-row _5 "> <div class=" td-pb-span td-sub-footer-menu _6m "> <div class=" menu-footer-links-container "><ul id="menu-footer-links" class=" td-subfooter-menu _6n "><li id="menu-item-18810" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item _v td-normal-menu _w menu-item-18810 "><a href="https://www.mysmartprice.com/gear/meet-our-team-2/" itemprop="url">Meet Our Team</a></li> <li id="menu-item-135215" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-135215 "><a href="https://www.mysmartprice.com/contact/" itemprop="url">Contact Us</a></li> <li id="menu-item-135214" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-135214 "><a href="https://www.mysmartprice.com/about/" itemprop="url">About MySmartPrice</a></li> <li id="menu-item-125548" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-125548 "><a href="https://www.mysmartprice.com/purpose/" itemprop="url">Purpose</a></li> <li id="menu-item-125549" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-125549 "><a href="https://www.mysmartprice.com/advertise/" itemprop="url">Advertise</a></li> <li id="menu-item-125550" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-125550 "><a href="https://www.mysmartprice.com/privacy/" itemprop="url">Privacy</a></li> <li id="menu-item-125551" class=" menu-item menu-item-type-custom menu-item-object-custom td-menu-item _v td-normal-menu _w menu-item-125551 "><a href="https://www.mysmartprice.com/terms/" itemprop="url">Terms of Use</a></li> <li id="menu-item-18812" class=" menu-item menu-item-type-post_type menu-item-object-page td-menu-item _v td-normal-menu _w menu-item-18812 "><a href="https://www.mysmartprice.com/gear/tip-us/" itemprop="url">Tip Us</a></li> </ul></div> </div> <div class=" td-pb-span td-sub-footer-copy _6l "> &copy; 2018 MySmartPrice Web Technology Private Limited </div> </div> </div> </div> </div>    <link rel="stylesheet" href="//www.mysmartprice.com/gear/wp-content/cache/swift-performance/www.mysmartprice.com/css/7bd84045d84afc72d849f155f201970b.css" media="all"><script src="//www.mysmartprice.com/gear/wp-content/cache/swift-performance/www.mysmartprice.com/js/072c7324720a0383ee06595b5cf8b5ce.js" type="text/javascript"></script> 
</body> </html>